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6.1  General Information  

6.1.1  Objectives 
Upon completion of this chapter, you will be able to: 

 Set up communication to controller AC 800M 

 Download and test hardware in online mode 

 

6.1.2  Legend 
> Indicates when you go from one menu to a sub-menu 

Italic Indicates object and file names 

“  “ Indicates dialog box buttons, tabs, menus etc. 

Bold Indicates important topics 

 Indicates start/explanation of student activity 

 

6.1.3  Reference Documentation 
3BSE036351 Industrial IT 800xA – Control and I/O 
 AC 800M Controller - Hardware and Operation 

3BSE041548 Industrial IT - Compact Control Builder AC 800M 
 Getting Started – Introduction and Installation 

3BSE040935 Industrial IT – Compact Control Builder AC 800M 
 Basic Control Software – Introduction and Configuration 
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6.2   Communication to AC800M Controller 
All controllers delivered from the factory have the same IP address. You must change 
the IP address to an address, which is available in your own network.  

6.2.1  How to Configure the IP Address with AC 800PEC 
A different procedure needs to be applied if an AC 800PEC controller is used. In order 
to manage the configuration of this controller (i.e. also configure the TCP/IP setting) a 
tool called PEC Configurator is used. 

The PEC Configurator reads the configuration from the controller and displays it to 
the user. The user has the possibility to change the configuration of the controller and 
store the modified configurations back to the target. 

 

 
 

Please, refer to the AC 800PEC PEC Configurator User Manual for a detailed 
description of this tool. 

 

You might also use the PC Installer for changing the IP-Address 
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6.2.2  How to Download the Firmware with AC 800PEC 
A tool called PEC Installer is used either to update the platform- and control software 
of an AC 800PEC controller and to backup the software from an AC 800PEC 
controller to the PC: in the PEC Installer, the first use case is called 'Download', the 
second one is called ‘Upload’. 

 
 

Do a backup (upload): 
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6.2.3  How to Configure the IP Address in the CBM 
After setting the controller’s IP address, you must do the IP address settings of the 
controller in CBM in two steps: 

1. Right click the Controller, choose “Properties > System Identity” and then set the 
desired IP address of the controller. 

 
 
The System Identity is the network address of the selected controller. The network 
address is shown beside the controller icon in the Project Explorer tree. 

NOTE! The default address is 172.16.0.0 
 

2. Open the controller’s PM8xx/TP830 and then double click the first Ethernet. 

 
 

This will open a new window, click on the “Settings” tab, then set the same IP address 
and subnet mask as you have set with the IPConfig tool. 
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NOTE! The system identity should normally correspond to the 
setting for Ethernet 1 on the AC800M. 
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6.3   Application Download 

6.3.1  General 
During a download, the code that has been written is checked and compiled. The 
controller receives the compiled application and begins executing it immediately. 

Once your application has been compiled, you can: 

 Download the application and go Online.  
This updates the application in the controller.  

 Go online without download of the application. 
Useful when, for example, monitoring values in the controller without disturbing 
the controller.  

A version analysis of the applications is made when you download. The analysis 
results are used to determine if and how applications shall be updated to new versions 
in the controllers.  

For the AC800PEC it is always recommended to load the application to the  

because of different  save cold retain value handling 

6.3.2  Restart Options 
When the system restarts, variables with No Retain, Retain and Cold Retain attributes 
will behave differently. It will also matter if the system performs a warm or a cold 
restart. 

 

WARM RESTART at AC800M only 

At a warm restart, variables with the attribute <retain> or <coldretain> are protected 
by the battery during restart. During the time that the controller is stopped, all output 
I/Os will keep their last value. 

COLD RESTART 

At a cold restart, variables with the attribute <coldretain> keep their values, since they 
are stored on the hard disk. Variables without the attribute <coldretain> lose their 
values. During the stop time, all output I/Os will keep their last safe state/OSP values. 

INIT RESTART  

At a Init restart, variables with the attribute <coldretain> or <retain> are returned to 
the initial value 
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6.3.3  Download to Flash 
 

For the AC800PEC use the Flash Utility tool to download. But first right click on the 
controller and “make” the compact flash. 

Select  “Programs > ABB Industrial IT AC 800 PEC….” 

At the very first time when you download to Ram only following windows will pop 
up: 

 
 

6.3.4  Download to RAM only 
 

Select “Tools > Download Project and go Online” in the CBM. 
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If changes have been made to one or several applications in Offline mode, the version 
analysis detects it. You can then decide how to restart the changed applications. 

 
 

Independent of how you restart the applications, the changed application parts are 
downloaded to the controllers. The controller will stop the applications and restart 
with the new and changed application. 

NOTE! Following download the last message should be: 
You are now Online! 
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6.3.5  Difference Report 
Just before the download to controllers, the system will open a ‘Difference Report’ 
window, which shows the differences between the applications on disk & applications 
in the controllers. At this time you may decide to continue or to cancel the download. 

The purpose of the difference report is validation of configuration changes. 

 
 

You may disable the difference report function in project context menu “Settings > 
Difference Report”. 
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6.4   Online Functions 

6.4.1  General 
In Online mode the Control Builder is connected to one or more controllers and offers 
many diagnostic and inspection features when online to the controller. You can: 

 View the executing code dynamically 

 Force inputs and outputs at the I/O modules 

 Rescale analogue input and output channels 

 Change values of variables 

 Inspect values of variables 
 

To enter Online mode, go to the tool bar menu of the Control Builder, click on 
“Tools” and then click on “Online”. 

 

6.4.2  Status of I/O-Signals 
Use the status tab of the hardware configuration editor, in online mode, for dynamic 
online display of I/O channel values and forcing. I/O channel values are updated once 
every second.  

NOTE! The tab is available in Offline mode, but is not editable. 

 
Underflow, overflow, channel and unit errors in online mode are indicated in the 
Channel value cell by the following icons: 

Signal Errors 
 underflow The signal is below the range. 

 overflow The signal is above the range. 

 

Hardware Errors 
channel error The channel can have under range, power-up or field power errors. 

Unit error The unit can be missing or of the wrong type. 
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6.4.3  Forcing 
Forcing of I/O is possible in online mode. Check a check box in the Forced column 
and then type in a value in the Channel value column for outputs and in the Variable 
value column for inputs. This value overrides the values in each of those columns.  

When a channel is forced all copying between the I/O value and the application value 
is stopped. The forced value is different for inputs and outputs.  

 For inputs the forcing changes the variable value to the application.   

 For outputs the forcing changes the physical I/O channel value.  

 
NOTE! The background of the forced cell changes to yellow to 

indicate forcing.  

 

Forcing is performed in the hardware configuration editor under the “Status” tab or the 
POU editor.  

Normally only channels with variable connections to application programs can be 
forced. However, if no variable is connected you have to change the parameter Copy 
Unconnected Channels under the “Settings” tab for the current controller to get a 
status update.  
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6.5  Test Mode & SoftController 

6.5.1  Test Mode 
Without downloading to a real controller or a SoftController, you may test your 
application by using the test mode. In CBM, select “Tools > Test mode”. 
 

6.5.2  How to use the SoftController 
You may also test your application and even your hardware by downloading to a 
SoftController running on your PC. It is also possible to use the SoftController for 
communication purposes, for example, COMLI or MODBUS. 

1. Set the controller’s system identity you want to test to your PC’s IP address:2 
(such as 172.16.0.1:2).  

NOTE! It is also possible to use the loop back adapter address as 
127.0.0.1:2. 
 

2. Right click the controller, select “Properties > Simulate Hardware” 
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3. Start the SoftController by double-click the icon on the desktop or choose the path 
below:

 
 

4. Click “Start”. 

 
 

5. Choose “Download project and Go online”. 
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Exercise 6.1  Downloading 

6.1.1  Description 
Perform a download of the project to the controller and set various Control Builder M 
options. 

 

6.1.2  Legend 
> Indicates when you go from one menu to a sub-menu 

Italic Indicates object and file names 

“  “ Indicates dialog box buttons, tabs, menus etc. 

Bold Indicates important topics 

 Indicates start/explanation of student activity  
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6.1.3  Exercise Steps 
 

6.1.3.1  Special Case PEC! 
For the AC800PEC use the Flash Utility tool to download. The first step is right click 
on the controller and “make” the data for the compact flash. 

 
 

The second step is downloading the file to the PEC 
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6.1.3.2  Download the Project to the Controller (only RAM) 
At the moment, our programming consists only of a single application, 
Sxx_ReactorApp, with some default diagnostic program running under the application 
(Program3). This will be sufficient to use for testing our ability to download. 

 

Three icons are located on Control Builder M’s toolbar (and also on the menu) which 
relate to downloading. Place your cursor over each of them momentarily to get a tool-
tip text what each of the icons does. 
 

“Test Mode” 
Compiles the application and the application executes in the local workstation. The 
application is NOT downloaded to the physical controller. Test mode is used for 
checking software before committing it to a controller. 

 
“On-line” 
CBM communicates directly with the controller to allow viewing of “live” or “on-
line” data. This may only be done if the current application in the controller is the 
same as that in Control Builder. No download occurs; the Control Builder just 
connects to the controller and its application. 

 
“Download to Ram only and Go Online” 
Causes a new compilation of the project files and downloads the compiled code to the 
controller. After this is done, Control Builder will be placed into the “online” mode as 
described above. The menu will provide you with the option to perform a coldstart of 
the new code and possibly a warmstart. For now, just accept the default start type. 

 
 

 Because this is the first time that the controller has been configured, you need to 
do a “Download and Go Online”. 
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The Online analysis window will compare the application code and hardware settings 
in the actual controller and Control Builder. 
 

 
 

 During the download, you will be presented with the “Difference Report.” To 
view an item of the report, double click on the item in the left-hand panel. The 
report will be presented in the right hand pane. 
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 Press the green check-box icon to continue when finished viewing the report. 

 
 

 To disable the Difference Report, right click on the project and select Settings > 
Difference Report. Remove the checkbox next to Enable Difference Report and 
click “OK”. 
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 From the “Tools” menu or using the icon on the toolbar, download to the 
controller and go online. 
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 Examine any hardware warnings (indicated in yellow on the project tree).  First 
right click on the warning and select “Clear Latched Unit Status”. 

 
 

 If the warnings do not clear, select the module editor and try to determine the 
cause of the warning.  For Analog Inputs, the warnings may be due to a channel 
Underflow which means the input value is less than the configured minimum. 
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 The DI801 module can be wired such that channel 16 is used to monitor the 
power for the digital input signals. Because we are not using that function, it is 
necessary to turn it off in software.  Select the editor for the module and change 
the value of the parameter “Sensor Power Supervision“ to “False”. 

NOTE! Control Builder must be offline to make any changes. 

  
 

 Download again to the controller. 

 Repeat this for the AI810 module and manipulate the potentiometers on the I/O 
Panel. 
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Exercise 6.2  Writing Simple Code 

6.2.1  Description 
Write some simple logic code using Structured Text. Declare variables and connect 
them to the input and output channels in the I/O system. 

Test the code in online mode and observe the status of simple Boolean variables. 
Force inputs and outputs using the hardware editor of the relevant I/O module. 

 

6.2.2  Legend 
> Indicates when you go from one menu to a sub-menu 

Italic Indicates object and file names 

“  “ Indicates dialog box buttons, tabs, menus etc. 

Bold Indicates important topics 

 Indicates start/explanation of student activity  
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6.2.3  Exercise Steps 
We will be writing some very simple and basic code to run in Program2 in the 
Sxx_ReactorApp application as an introduction to using the POU editor functions.  

NOTE! The editor must be in on off-line mode! 

 
6.2.3.1  Declare Variables 

 Open Program2 in application Sxx_ReactorApp. 

 

 
 

Declaration 
Pane 

Message 
Pane 

Code Pane 
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 We will need to declare variables to hold the values represented by our I/O points.  
Declare 4 BoolIO variables called SW1, SW2, SW3, and Lamp1 with no attributes. 

 
NOTE! Because these values are directly associated with I/O, no 

retain-type attributes will be set. 

Entries in the “Data Type” and “Attributes” columns may be typed in directly, if 
known, or a pick-list can be obtained by placing the cursor in the desired cell in the 
editor and pressing <CTRL-J>.  

 After making changes check the Program for any errors. 

 
 

If Control Builder detects errors, they will be shown in the message (lower) pane in 
the POU editor. This pane may have to be enabled by selecting “View > Messages 
Pane” from the menu.  

Double-click on an error in the message pane to locate the cursor where the error was 
detected. 

 

Cursor 
Shown on 

Error 
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6.2.3.2  Write Logic 
We will need to write some logic in the Code Pane in the editor. Programming will 
actually be covered in several lessons later in the course. We will be inserting some 
programming code in the Structured Text (ST) language – the default language the 
editor opened up with. 

The logic behind our code is very simple. It will evaluate three Digital Inputs and set a 
Digital Output according to the logic diagram below: 

 
The SW1, SW2, and SW3 variables will be connected to three channels of a digital 
input module (which are wired to switches) and the Lamp1 variable will be connected 
to a channel on a digital output module (which is wired to an indicating light).  

 Type the following line directly in the Code Pane area in the editor. Note that the = 
sign is actually preceded by a colon and the line must end with a semicolon.  

Lamp1.Value := (SW1.Value AND SW2.Value) OR SW3.Value; 
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 Perform a check of your syntax by clicking on the “Check” icon in the tool bar: You 
should get 0 Errors and 0 Warnings. 

 
 

 Save and close the POU editor. 
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 Do an off-line test of the logic by taking Control Builder to Test Mode. Click the 
“Continue” button for the On Line Change analysis dialog and observe that Control 
Builder enters the “Test” mode by checking the Message Pane in Control Builder.  

 
 

 Take Control Builder to the Off-line mode by pressing the “Stop Test Mode” icon on 
the toolbar. 

 
 

 
6.2.3.3  Connect Variables to I/O Channels  

Once variables have been defined (and saved) in a POU editor, they can then become 
available to connect to the actual hardware channel itself. This is called “I/O 
Allocation”. I/O allocation is configured in the editor window for each specific I/O 
module.  

Right click on the I/O module to open the Hardware editor and selecting “Editor” or 
double-click the module object itself. The settings available on each editor will be 
different depending upon the hardware module type.  
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 Open up the hardware structure in the Control Builder and double click on the DI810 
module in the tree: 

 

 Connect the three switches on the DI810 module to the SW1, SW2, and SW3 variables 
you created in “Program2”. Use the icons in the upper right corner of the editor to 
choose variables. Save and close the editor when finished. 

 
 

 Connect the first channel on the DO810 module to the Lamp1 variable you created in 
Program2. Check for errors and then save and close the editor when finished. 

 
 

Full Path to 
Variable 
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6.2.3.4  Download and Go Online 

 Download your project to the controller. 

 
 

6.2.3.5  Viewing Code in Online Mode 

 Ensure Control Builder is in the Online mode and open the POU editor for Program 2 
and observer your logic in on-line mode. Manipulate the three switches and observe 
the light on the I/O panel while looking at your logic. 

 
 

 Right click on the variable in the Declaration Pane to get information about the 
variable and also to open the I/O editor. 

 
 

Indicates 
Value of the 

Variable 

Dark Blue 
Indicates 

Variable is True 
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6.2.3.6  Change the Online View of Structured Text (ST) 

If your code is written in ST, you can alter the views of your logic to either Function 
Diagram or Ladder (other available programming languages).  
Select Tools > Setup from the program editor menu bar. 

 

 View the logic on-line in the Function Diagram language. 
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 View the logic on-line in the Ladder language. 

 

 Change the view back to “Text”. 
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6.2.3.7  Force I/O Signals 
I/O may be forced from the “Status” tab in the Hardware editor for the particular I/O 
module. The editor will have two columns of interest.  

 “Channel Value” indicates the actual measured value at the I/O module 

 “Variable Value” indicates the value of the variable in the program logic that the 
I/O channel is connected to 

These two values will be equal if the channel is not forced. For input modules, you can 
change the value of the variable being written to by the I/O module. For output 
modules, you can force the channel’s output value. 

 Right-click on the SW1 variable and select “I/O Editor” to open the hardware editor 
for the DI810 module. 

 
 

 Ensure the “Status” tab is selected at the bottom of the hardware editor and force one 
or more variables. Observe the resulting changes in your Program2 editor’s code pane 
as you force and release forces on variables. 
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Solution 6.2  Writing Simple Code 

6.2.1  Description 

Write some simple logic code using Structured Text. Declare variables and connect 
them to the input and output channels in the IO system. 

Test the code in online mode and observe the status of simple Boolean variables. 
Force inputs and outputs using the hardware editor of the relevant IO module. 

 

6.2.2  Legend 

> Indicates when you go from one menu to a sub-menu 

Italic Indicates object and file names 

“  “ Indicates dialog box buttons, tabs, menus etc. 

Bold Indicates important topics 

           Indicates start/explanation of student activity  
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6.2.3  Solution Steps 

We will be writing some very simple and basic code to run in Program2 in the 
Sxx_ReactorApp application as an introduction to using the POU editor functions.  

NOTE! The editor must be in on off-line mode! 

 
6.2.3.1  Declare Variables 

 Open Program2 in application Sxx_ReactorApp. 

1. Make sure that Control Builder M is in offline mode 

2. Expand the Applications object and select Program2 located under your 
Sxx_ReactorApp object. You can open the POU for this program either by 
double-clicking Program2 or right-clicking and selecting “Editor” from the 
context menu. 
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3. Locate the available panes, tabs, and menu items to allow you to navigate in the 
editor window. 

 
 

Declaration 
Pane 

Message 
Pane 

Code Pane 



T530-06 Solution 6.2 - RevG 

Solution 6.2  - 4 
 

 Declare 4 BoolIO variables called SW1, SW2, SW3, and LAMP1 with no attributes. 

1. Make sure you are selected to the “Variables” tab in the declaration (upper) pane 
in the POU editor and enter the names of the variable in the “Name” column. 

 
2. Place your cursor in the DataType column and press <CTRL-J> and select the 

data type “BoolIO”. 

 
3. Also try selecting the “Insert…” Icon on the upper right corner of the POU editor 

window. 
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4. Delete the retain attributes which by default will be added when creating 
variables. Select the entire “Attributes” column by clicking on the column header 
and delete all entries by pressing the “delete” key on the keyboard. 

 
 

5. Or mark with the mouse and right click, select “Clear” 

 
 

6. Check the POU for errors. In the tab “check” the 0 Errors, 0 warnings 

 
 

7. Save  
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6.2.3.2  Write Logic 

 The logic must valuate three Digital Inputs and set a Digital Output according to the 
logic diagram 
below:

 
1. Type the following line directly in the Code Pane area in the editor. 

Lamp1.Value := (SW1.Value AND SW2.Value) OR SW3.Value; 
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2. The already defined variables can be marked from a list using keyboard Ctrl J  
The following keyboard code can be used: 
Ctrl j, arrow down, select SW1, Enter,  
.(dot), arrow down, select Value, Enter. 
Arrow down can be replaced by typing the first letter in the item of the list 

 
 

3. Select the keyboard . (dot) behind the SW1 and the Value will be browsed 

 
 

4. Select the ‘Check’ Icon in the tool bar: You should get 0 Errors and 0 Warnings. 

 
 
 

5. Save and close the POU editor. 
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6. Select “Test Mode”.  

 
 

7. Click the “Continue” button for the On Line Change analysis dialog and observe 
that Control Builder enters the “Test” mode 
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8. Check the Message Pane in Control Builder.  

 
 

9. Take Control Builder to the Off-line mode by pressing the “Stop Test Mode” icon 
on the toolbar. 

 
 

 
6.2.3.3  Connect Variables to IO Channels  

 Connect the three switches on the DI810 module to the SW1, SW2, and SW3 variable 
you created in Program2 
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1. Open up the hardware structure in the Control Builder and double click on the 
DI810 module in the tree: 

 
2. Connect the three switches on the DI810 module to the SW1, SW2, and SW3 

variables you created in “Program2”. Use the icons in the upper right corner of 
the editor to choose variables. Open the tree to view the variables, select the +  

 
3. Save and close the editor when finished. 

 
 

Full Path to 
Variable 
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4. Select DO810 

 
5. Connect the first channel on the DO810 module to the Lamp1 variable you 

created in Program2. Check for errors and then save and close the editor when 
finished. 

 
 

6. Download and Go Online. Select “Continue” 
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6.2.3.4  View Code in Online Mode 

 Check Control Builder is in the On-Line mode and open the POU editor for Program 2 
and observe the logic is in on-line mode.  

1. Manipulate the three switches and observe the light on the IO panel while looking 
at your logic. 

 
2. .  

Right click on the variable in the Declaration Pane to get information about the 
variable and also to open the I/O editor. on  

Indicates 
Value of the 

Variable 

Dark Blue 
Indicates 

Variable is 
True 
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3. For information right click at a variable 

 
 

4. Read the information regarding to I/O address and Application 

 
 

5. Select the hardware tab “Status” to view the connections  
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6.2.3.5  Change the Online View of Structured Text (ST) 
1. Select Tools > Setup from the program editor menu bar. 

 
2. Select radio button for Function Diagram, Select “OK” 

 
3. View the logic on-line in the Function Diagram language. 

 
4. View the logic on-line in the Ladder language. 
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5. Change a switch at the panel. 

 
6. Change the view back to Text. 
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 Forcing IO 

1. Open the hardware editor screen for the DI810 module by right-clicking the SW1 
variable in the program editor and selecting “I/O Editor” from the context menu. 

 
 

 

2. Select the “Status”, and force one or more variables. Observe the resulting 
changes in your Program2 editor’s code pane as you force and release forces on 
variables. 

 
 

 
 


